Critical Update for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 | Microsoft

Important All future security and nonsecurity updates for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 require this update to be installed. We recommend that you install this update on your Windows RT 8.1, Windows 8.1, or Windows Server 2012 R2-based computer in order to receive continued future updates.

What this means is that unless you get this patch onto your client machines they will be unable to download and install security updates from May onwards… therefore you NEED TO GET THIS TESTED AND DEPLOYED OUT SOONER THAN LATER.

Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 Update April, 2014.

Bookmark the permalink.

Comments are closed